const regex = new RegExp('(?:[^][]|\\[[^][]*])*\\.\\w{2,}', 'gm')
const str = `[Text]-[Text]-[Filename[Uploader].txt]-[1/23] - "" yEnc 1234567890 (1/23456)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}