import re
regex = re.compile(r"(?:[^][]|\[[^][]*])*\.\w{2,}", flags=re.MULTILINE)
test_str = "[Text]-[Text]-[Filename[Uploader].txt]-[1/23] - \"\" yEnc 1234567890 (1/23456)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")