$re = '/(?:[^][]|\[[^][]*])*\.\w{2,}/m';
$str = '[Text]-[Text]-[Filename[Uploader].txt]-[1/23] - "" yEnc 1234567890 (1/23456)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);