re = /(?:[^][]|\[[^][]*])*\.\w{2,}/m
str = '[Text]-[Text]-[Filename[Uploader].txt]-[1/23] - "" yEnc 1234567890 (1/23456)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end