import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?!\\2\\b|\\3\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+)[,.; ]+)(?>(?!\\1\\b|\\3\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+)[,.; ]+)(?>(?!\\1\\b|\\2\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+))$";
final String string = "1,2,12\n"
+ "22,3, 21\n"
+ "1,,,,22,,,,19\n"
+ "9. 12,.. 8\n"
+ "1.1. 2\n"
+ "2. 1. 2\n"
+ "3,3,12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}