re = /^(?>(?!\2\b|\3\b)(1\d{1}|2[0-2]{1}|\d{1}+)[,.; ]+)(?>(?!\1\b|\3\b)(1\d{1}|2[0-2]{1}|\d{1}+)[,.; ]+)(?>(?!\1\b|\2\b)(1\d{1}|2[0-2]{1}|\d{1}+))$/m
str = '1,2,12
22,3, 21
1,,,,22,,,,19
9. 12,.. 8
1.1. 2
2. 1. 2
3,3,12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end