const regex = /^(?>(?!\2\b|\3\b)(1\d{1}|2[0-2]{1}|\d{1}+)[,.; ]+)(?>(?!\1\b|\3\b)(1\d{1}|2[0-2]{1}|\d{1}+)[,.; ]+)(?>(?!\1\b|\2\b)(1\d{1}|2[0-2]{1}|\d{1}+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>(?!\\2\\b|\\3\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+)[,.; ]+)(?>(?!\\1\\b|\\3\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+)[,.; ]+)(?>(?!\\1\\b|\\2\\b)(1\\d{1}|2[0-2]{1}|\\d{1}+))$', 'gm')
const str = `1,2,12
22,3, 21
1,,,,22,,,,19
9. 12,.. 8
1.1. 2
2. 1. 2
3,3,12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}