#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s|\))like(\s|\()"
Local $sString = "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')" & @CRLF & _
"where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b" & @CRLF & _
"where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")