re = /(\s|\))like(\s|\()/
str = 'where ( i like \'b\' ) and concat(a,b) like (\'%\'+@p2+\'%\')
where ( i like \'b\' ) and concat(a,b) like (\'%\'+@p2+\'%\') and a like b
where ( i like \'b\' ) and a like b and concat(a,b) like (\'%\'+@p2+\'%\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end