import Foundation
let pattern = #"(\s|\))like(\s|\()"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b
where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)