// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s|\))like(\s|\()").unwrap();
let string = "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b
where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}