const regex = /(?<Message>.*)[\.](?:[\s]id:(?<id>.*)[\.])? Code:(?<Code>.*)[\.]/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Message>.*)[\\.](?:[\\s]id:(?<id>.*)[\\.])? Code:(?<Code>.*)[\\.]', 'img')
const str = `Failed to send sms. code:5063.
Failed to send sms. id:23. code:5063.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}