$re = '/(?<Message>.*)[\.](?:[\s]id:(?<id>.*)[\.])? Code:(?<Code>.*)[\.]/im';
$str = 'Failed to send sms. code:5063.
Failed to send sms. id:23. code:5063.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);