#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([0-9]{1,2}:?(?:[0-9]{2})?)-([0-9]{1,2}:?(?:[0-9]{2})?)\s(AM|PM)"
Local $sString = "@HOME 8:30-4:15 PM: Full analysis of Concur report (EFF) > Q1 report (Stan 5/6/15) > Sign-in Sheets (127 meetings)" & @CRLF & _
"" & @CRLF & _
"@HUB 2:30-3:30 PM: Planning and meeting with Stanley Braxton" & @CRLF & _
"" & @CRLF & _
"@HUB 9-4 PM, 6-8 PM: Ashfield HCPHUB configuration; (Old) expenses analysis from Stan; Gaining Concur access from Covis (Dawn)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")