import Foundation
let pattern = #"([0-9]{1,2}:?(?:[0-9]{2})?)-([0-9]{1,2}:?(?:[0-9]{2})?)\s(AM|PM)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
@HOME 8:30-4:15 PM: Full analysis of Concur report (EFF) > Q1 report (Stan 5/6/15) > Sign-in Sheets (127 meetings)
@HUB 2:30-3:30 PM: Planning and meeting with Stanley Braxton
@HUB 9-4 PM, 6-8 PM: Ashfield HCPHUB configuration; (Old) expenses analysis from Stan; Gaining Concur access from Covis (Dawn)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)