using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$";
string input = @"1111111111
1111111111.00
1111111111,00
1,111,111,111.00
1.111.111.111,00
-1111111111
-1111111111.00
-1111111111,00
-1,111,111,111.00
-1.111.111.111,00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}