import re
regex = re.compile(r"^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$", flags=re.MULTILINE)
test_str = ("1111111111\n"
"1111111111.00\n"
"1111111111,00\n"
"1,111,111,111.00\n"
"1.111.111.111,00\n\n"
"-1111111111\n"
"-1111111111.00\n"
"-1111111111,00\n"
"-1,111,111,111.00\n"
"-1.111.111.111,00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")