package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$`)
var str = `1111111111
1111111111.00
1111111111,00
1,111,111,111.00
1.111.111.111,00
-1111111111
-1111111111.00
-1111111111,00
-1,111,111,111.00
-1.111.111.111,00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}