const regex = /'?(\s|$)(?=(([^']*'){2})*[^']*$)'?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'?(\\s|$)(?=(([^\']*\'){2})*[^\']*$)\'?', 'gm')
const str = `param1 param2 'param3 param3 param3' param4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);