$re = '/\'?(\s|$)(?=(([^\']*\'){2})*[^\']*$)\'?/m';
$str = 'param1 param2 \'param3 param3 param3\' param4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;