re = /'?(\s|$)(?=(([^']*'){2})*[^']*$)'?/m
str = 'param1 param2 \'param3 param3 param3\' param4'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result