use strict;
my $str = 'param1 param2 \'param3 param3 param3\' param4';
my $regex = qr/'?(\s|$)(?=(([^']*'){2})*[^']*$)'?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";