#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?><STARTTAG1>(?<text1>.*?)<ENDTAG1>)(?:(?!<STARTTAG1>).)*?<STARTTAG2>(?<text2>.*?)<ENDTAG2>"
Local $sString = "Some random text here <STARTTAG1>text to match<ENDTAG1> some more " & @CRLF & _
"random text <STARTTAG2>text to match<ENDTAG2> more random text " & @CRLF & _
"Some random text here <STARTTAG1>I don't want this text to match<ENDTAG1> some more " & @CRLF & _
"random text more random text " & @CRLF & _
"Some random text here <STARTTAG1>text to match<ENDTAG1> some more " & @CRLF & _
"random text <STARTTAG2>text to match<ENDTAG2> more random text "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")