use strict;
my $str = 'Some random text here <STARTTAG1>text to match<ENDTAG1> some more
random text <STARTTAG2>text to match<ENDTAG2> more random text
Some random text here <STARTTAG1>I don\'t want this text to match<ENDTAG1> some more
random text more random text
Some random text here <STARTTAG1>text to match<ENDTAG1> some more
random text <STARTTAG2>text to match<ENDTAG2> more random text ';
my $regex = qr/(?><STARTTAG1>(?<text1>.*?)<ENDTAG1>)(?:(?!<STARTTAG1>).)*?<STARTTAG2>(?<text2>.*?)<ENDTAG2>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}