# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?><STARTTAG1>(?<text1>.*?)<ENDTAG1>)(?:(?!<STARTTAG1>).)*?<STARTTAG2>(?<text2>.*?)<ENDTAG2>"
test_str = ("Some random text here <STARTTAG1>text to match<ENDTAG1> some more \n"
"random text <STARTTAG2>text to match<ENDTAG2> more random text \n"
"Some random text here <STARTTAG1>I don't want this text to match<ENDTAG1> some more \n"
"random text more random text \n"
"Some random text here <STARTTAG1>text to match<ENDTAG1> some more \n"
"random text <STARTTAG2>text to match<ENDTAG2> more random text ")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.