re = /(?><STARTTAG1>(?<text1>.*?)<ENDTAG1>)(?:(?!<STARTTAG1>).)*?<STARTTAG2>(?<text2>.*?)<ENDTAG2>/
str = 'Some random text here <STARTTAG1>text to match<ENDTAG1> some more
random text <STARTTAG2>text to match<ENDTAG2> more random text
Some random text here <STARTTAG1>I don\'t want this text to match<ENDTAG1> some more
random text more random text
Some random text here <STARTTAG1>text to match<ENDTAG1> some more
random text <STARTTAG2>text to match<ENDTAG2> more random text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end