package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))\.){3}(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))$`)
var str = `128.1.1.0
256.12.34.33
255.12.34.33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}