re = /^(?:(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))\.){3}(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))$/m
str = '128.1.1.0
256.12.34.33
255.12.34.33'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end