const regex = /^(?:(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))\.){3}(?:\d{1,2}|1\d{2}|2(?:[0-4]\d|5[0-5]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d{1,2}|1\\d{2}|2(?:[0-4]\\d|5[0-5]))\\.){3}(?:\\d{1,2}|1\\d{2}|2(?:[0-4]\\d|5[0-5]))$', 'gm')
const str = `128.1.1.0
256.12.34.33
255.12.34.33`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}