import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d{1,2}|1\\d{2}|2(?:[0-4]\\d|5[0-5]))\\.){3}(?:\\d{1,2}|1\\d{2}|2(?:[0-4]\\d|5[0-5]))$";
final String string = "128.1.1.0\n"
+ "256.12.34.33\n"
+ "255.12.34.33";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}