using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\s+\w+.*?>";
string input = @" <a href=""http://chat.stackoverflow.com"" class=""js-gps-track"" data-gps-track=""site_switcher.click({ item_type:6 })""
>
<a>
<a><a><a>
<asdf><a><a had=""asdfds""><a><a>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}