re = /<(\w+)\s+\w+.*?>/
str = ' <a href="http://chat.stackoverflow.com" class="js-gps-track" data-gps-track="site_switcher.click({ item_type:6 })"
>
<a>
<a><a><a>
<asdf><a><a had="asdfds"><a><a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end