const regex = /<(\w+)\s+\w+.*?>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)\\s+\\w+.*?>', 'gs')
const str = ` <a href="http://chat.stackoverflow.com" class="js-gps-track" data-gps-track="site_switcher.click({ item_type:6 })"
>
<a>
<a><a><a>
<asdf><a><a had="asdfds"><a><a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}