$re = '/<(\w+)\s+\w+.*?>/s';
$str = ' <a href="http://chat.stackoverflow.com" class="js-gps-track" data-gps-track="site_switcher.click({ item_type:6 })"
>
<a>
<a><a><a>
<asdf><a><a had="asdfds"><a><a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);