#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$"
Local $sString = "102,00" & @CRLF & _
"103,78" & @CRLF & _
"1.000,34" & @CRLF & _
"11.000,00" & @CRLF & _
"11.000,10" & @CRLF & _
"100,10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")