re = /^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$/m
str = '102,00
103,78
1.000,34
11.000,00
11.000,10
100,10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end