$re = '/<img\b[^>]*\bsrc\s*=\s*([\'"])(.*?)\1/';
$str = 'hello, here\'s an <img alt="image" src="some://url"/> and here\'s a <video src="not://interested"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);