re = /<img\b[^>]*\bsrc\s*=\s*(['"])(.*?)\1/
str = 'hello, here\'s an <img alt="image" src="some://url"/> and here\'s a <video src="not://interested"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end