#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\"apps\"\s+{\s+(\"(\d+)\"\s+\"\d+\"\s+)+\s+}"
Local $sString = ""libraryfolders"" & @CRLF & _
"{" & @CRLF & _
" "0"" & @CRLF & _
" {" & @CRLF & _
" "path" "C:\\Program Files (x86)\\Steam"" & @CRLF & _
" "label" """ & @CRLF & _
" "contentid" "-4617057559629097284"" & @CRLF & _
" "totalsize" "0"" & @CRLF & _
" "update_clean_bytes_tally" "26071119336"" & @CRLF & _
" "time_last_update_corruption" "0"" & @CRLF & _
" "apps"" & @CRLF & _
" {" & @CRLF & _
" "228980" "419015490"" & @CRLF & _
" "250820" "5600094877"" & @CRLF & _
" "705900" "2514926917"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" "1"" & @CRLF & _
" {" & @CRLF & _
" "path" "N:\\SteamLibrary"" & @CRLF & _
" "label" """ & @CRLF & _
" "contentid" "3764071818320917735"" & @CRLF & _
" "totalsize" "1000186310656"" & @CRLF & _
" "update_clean_bytes_tally" "225615218162"" & @CRLF & _
" "time_last_update_corruption" "0"" & @CRLF & _
" "apps"" & @CRLF & _
" {" & @CRLF & _
" "221680" "7000427217"" & @CRLF & _
" "223750" "221071349004"" & @CRLF & _
" "223850" "3121585480"" & @CRLF & _
" "236390" "45325788243"" & @CRLF & _
" "348250" "2996347031"" & @CRLF & _
" "438100" "832697714"" & @CRLF & _
" "450390" "16625763869"" & @CRLF & _
" "546560" "72900756522"" & @CRLF & _
" "578080" "35943596276"" & @CRLF & _
" "667970" "2603561151"" & @CRLF & _
" "690790" "117594033997"" & @CRLF & _
" "1118240" "2213415708"" & @CRLF & _
" "1174180" "128249349313"" & @CRLF & _
" "1250410" "1865648550"" & @CRLF & _
" "1255560" "9741578437"" & @CRLF & _
" "1517290" "66609320436"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")