# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"apps\"\s+{\s+(\"(\d+)\"\s+\"\d+\"\s+)+\s+}"
test_str = ("\"libraryfolders\"\n"
"{\n"
" \"0\"\n"
" {\n"
" \"path\" \"C:\\\\Program Files (x86)\\\\Steam\"\n"
" \"label\" \"\"\n"
" \"contentid\" \"-4617057559629097284\"\n"
" \"totalsize\" \"0\"\n"
" \"update_clean_bytes_tally\" \"26071119336\"\n"
" \"time_last_update_corruption\" \"0\"\n"
" \"apps\"\n"
" {\n"
" \"228980\" \"419015490\"\n"
" \"250820\" \"5600094877\"\n"
" \"705900\" \"2514926917\"\n"
" }\n"
" }\n"
" \"1\"\n"
" {\n"
" \"path\" \"N:\\\\SteamLibrary\"\n"
" \"label\" \"\"\n"
" \"contentid\" \"3764071818320917735\"\n"
" \"totalsize\" \"1000186310656\"\n"
" \"update_clean_bytes_tally\" \"225615218162\"\n"
" \"time_last_update_corruption\" \"0\"\n"
" \"apps\"\n"
" {\n"
" \"221680\" \"7000427217\"\n"
" \"223750\" \"221071349004\"\n"
" \"223850\" \"3121585480\"\n"
" \"236390\" \"45325788243\"\n"
" \"348250\" \"2996347031\"\n"
" \"438100\" \"832697714\"\n"
" \"450390\" \"16625763869\"\n"
" \"546560\" \"72900756522\"\n"
" \"578080\" \"35943596276\"\n"
" \"667970\" \"2603561151\"\n"
" \"690790\" \"117594033997\"\n"
" \"1118240\" \"2213415708\"\n"
" \"1174180\" \"128249349313\"\n"
" \"1250410\" \"1865648550\"\n"
" \"1255560\" \"9741578437\"\n"
" \"1517290\" \"66609320436\"\n"
" }\n"
" }\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.