re = /\"apps\"\s+{\s+(\"(\d+)\"\s+\"\d+\"\s+)+\s+}/m
str = '"libraryfolders"
{
"0"
{
"path" "C:\\\\Program Files (x86)\\\\Steam"
"label" ""
"contentid" "-4617057559629097284"
"totalsize" "0"
"update_clean_bytes_tally" "26071119336"
"time_last_update_corruption" "0"
"apps"
{
"228980" "419015490"
"250820" "5600094877"
"705900" "2514926917"
}
}
"1"
{
"path" "N:\\\\SteamLibrary"
"label" ""
"contentid" "3764071818320917735"
"totalsize" "1000186310656"
"update_clean_bytes_tally" "225615218162"
"time_last_update_corruption" "0"
"apps"
{
"221680" "7000427217"
"223750" "221071349004"
"223850" "3121585480"
"236390" "45325788243"
"348250" "2996347031"
"438100" "832697714"
"450390" "16625763869"
"546560" "72900756522"
"578080" "35943596276"
"667970" "2603561151"
"690790" "117594033997"
"1118240" "2213415708"
"1174180" "128249349313"
"1250410" "1865648550"
"1255560" "9741578437"
"1517290" "66609320436"
}
}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end