import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"apps\\\"\\s+\\{\\s+(\\\"(\\d+)\\\"\\s+\\\"\\d+\\\"\\s+)+\\s+\\}";
final String string = "\"libraryfolders\"\n"
+ "{\n"
+ " \"0\"\n"
+ " {\n"
+ " \"path\" \"C:\\\\Program Files (x86)\\\\Steam\"\n"
+ " \"label\" \"\"\n"
+ " \"contentid\" \"-4617057559629097284\"\n"
+ " \"totalsize\" \"0\"\n"
+ " \"update_clean_bytes_tally\" \"26071119336\"\n"
+ " \"time_last_update_corruption\" \"0\"\n"
+ " \"apps\"\n"
+ " {\n"
+ " \"228980\" \"419015490\"\n"
+ " \"250820\" \"5600094877\"\n"
+ " \"705900\" \"2514926917\"\n"
+ " }\n"
+ " }\n"
+ " \"1\"\n"
+ " {\n"
+ " \"path\" \"N:\\\\SteamLibrary\"\n"
+ " \"label\" \"\"\n"
+ " \"contentid\" \"3764071818320917735\"\n"
+ " \"totalsize\" \"1000186310656\"\n"
+ " \"update_clean_bytes_tally\" \"225615218162\"\n"
+ " \"time_last_update_corruption\" \"0\"\n"
+ " \"apps\"\n"
+ " {\n"
+ " \"221680\" \"7000427217\"\n"
+ " \"223750\" \"221071349004\"\n"
+ " \"223850\" \"3121585480\"\n"
+ " \"236390\" \"45325788243\"\n"
+ " \"348250\" \"2996347031\"\n"
+ " \"438100\" \"832697714\"\n"
+ " \"450390\" \"16625763869\"\n"
+ " \"546560\" \"72900756522\"\n"
+ " \"578080\" \"35943596276\"\n"
+ " \"667970\" \"2603561151\"\n"
+ " \"690790\" \"117594033997\"\n"
+ " \"1118240\" \"2213415708\"\n"
+ " \"1174180\" \"128249349313\"\n"
+ " \"1250410\" \"1865648550\"\n"
+ " \"1255560\" \"9741578437\"\n"
+ " \"1517290\" \"66609320436\"\n"
+ " }\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}