import re
regex = re.compile(r""", flags=re.MULTILINE)
test_str = ""href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Prologue","label":"Prologue","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_01%3A_The_Lure_of_Adventure","label":"Chapter 01: The Lure of Adventure","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_02%3A_Infernal_Place","label":"Chapter 02: Infernal Place","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_03%3A_The_Malaysia_Job","label":"Chapter 03: The Malaysia Job","sub":[],"sub_cn":["ghn-tertNav"],"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")