import Foundation
let pattern = #"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""href":"\/wikis\/uncharted-4-a-thiefs-end\/Prologue","label":"Prologue","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\/wikis\/uncharted-4-a-thiefs-end\/Chapter_01%3A_The_Lure_of_Adventure","label":"Chapter 01: The Lure of Adventure","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\/wikis\/uncharted-4-a-thiefs-end\/Chapter_02%3A_Infernal_Place","label":"Chapter 02: Infernal Place","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\/wikis\/uncharted-4-a-thiefs-end\/Chapter_03%3A_The_Malaysia_Job","label":"Chapter 03: The Malaysia Job","sub":[],"sub_cn":["ghn-tertNav"],"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}