import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^09[0-9'@s]{9,9}$";
final String string = "11111111\n"
+ "111111111\n"
+ "(11) 11111111\n"
+ "(11) 111111111\n"
+ "+11 (11) 11111111\n"
+ "+11 (11) 111111111\n\n"
+ "1111-1111\n"
+ "11111-1111\n"
+ "(11) 1111-1111\n"
+ "(11) 11111-1111\n"
+ "+11 (11) 1111-1111\n"
+ "+11 (11) 11111-1111\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}