import re
regex = re.compile(r"^09[0-9'@s]{9,9}$", flags=re.MULTILINE)
test_str = ("11111111\n"
"111111111\n"
"(11) 11111111\n"
"(11) 111111111\n"
"+11 (11) 11111111\n"
"+11 (11) 111111111\n\n"
"1111-1111\n"
"11111-1111\n"
"(11) 1111-1111\n"
"(11) 11111-1111\n"
"+11 (11) 1111-1111\n"
"+11 (11) 11111-1111\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")