$re = '/^09[0-9\'@s]{9,9}$/m';
$str = '11111111
111111111
(11) 11111111
(11) 111111111
+11 (11) 11111111
+11 (11) 111111111
1111-1111
11111-1111
(11) 1111-1111
(11) 11111-1111
+11 (11) 1111-1111
+11 (11) 11111-1111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);