re = /^09[0-9'@s]{9,9}$/m
str = '11111111
111111111
(11) 11111111
(11) 111111111
+11 (11) 11111111
+11 (11) 111111111
1111-1111
11111-1111
(11) 1111-1111
(11) 11111-1111
+11 (11) 1111-1111
+11 (11) 11111-1111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end