package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0?[1-9]|1[012])\/(0?[1-9]|[12]\d|3[01])\/[12]\d{3} ([01]\d|2[0-3])\:[0-5]\d\:[0-5]\d$`)
var str = `
2/2/2013 00:00:00
2/2/2013 12:30:20`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}