import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0?[1-9]|1[012])\\/(0?[1-9]|[12]\\d|3[01])\\/[12]\\d{3} ([01]\\d|2[0-3])\\:[0-5]\\d\\:[0-5]\\d$";
final String string = "\n"
+ "2/2/2013 00:00:00\n\n"
+ "2/2/2013 12:30:20";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}